`

HDU 1234 开门人和关门人 .

STL 
阅读更多

开门人和关门人

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 5354    Accepted Submission(s): 2759

Problem Description
每天第一个到机房的人要把门打开,最后一个离开的人要把门关好。现有一堆杂乱的机房签
到、签离记录,请根据记录找出当天开门和关门的人。
 

 

Input
测试输入的第一行给出记录的总天数N ( > 0 )。下面列出了N天的记录。
每天的记录在第一行给出记录的条目数M ( > 0 ),下面是M行,每行的格式为

证件号码 签到时间 签离时间

其中时间按“小时:分钟:秒钟”(各占2位)给出,证件号码是长度不超过15的字符串。
 

 

Output
对每一天的记录输出1行,即当天开门和关门人的证件号码,中间用1空格分隔。
注意:在裁判的标准测试输入中,所有记录保证完整,每个人的签到时间在签离时间之前,
且没有多人同时签到或者签离的情况。
 

 

Sample Input
3 1 ME3021112225321 00:00:00 23:59:59 2 EE301218 08:05:35 20:56:35 MA301134 12:35:45 21:40:42 3 CS301111 15:30:28 17:00:10 SC3021234 08:00:00 11:25:25 CS301133 21:45:00 21:58:40
 

 

Sample Output
ME3021112225321 ME3021112225321 EE301218 MA301134 SC3021234 CS301133
 

 

Source
 

 

Recommend
JGShining
 
水题一条,呢度主要演示STL,同埋运算符重载。
下面代码:
4285170 2011-07-29 11:19:50 Accepted 1234 15MS 268K 1038 B C++ 10SGetEternal{(。)(。)}!
#include <iostream>
#include <vector>
#include <algorithm>
using namespace std;

struct time
{
    int h, m, s;

    bool operator < (time &o)
    {
        if (h == o.h)
        {
            if (m == o.m)
            {
                return s < o.s;
            }
            else return m < o.m;
        }
        else return h < o.h;
    }
};

struct person
{
    char id[20];
    time in, out;
};

bool cmpi(person &a, person &b) { return a.in < b.in; }
bool cmpo(person &a, person &b) { return a.out < b.out; }

vector<person> dayp;

int main()
{
    int n, m;
    person tmp;

    while (scanf("%d", &n) != EOF)
    {
        while (n--)
        {
            dayp.resize(0);
            scanf("%d", &m);
            while (m--)
            {
                scanf("%s %d:%d:%d %d:%d:%d",
                       &tmp.id,
                       &tmp.in.h, &tmp.in.m, &tmp.in.s,
                       &tmp.out.h, &tmp.out.m, &tmp.out.s);
                dayp.push_back(tmp);
            }
            sort(dayp.begin(), dayp.begin() + dayp.size(), cmpi);
            printf("%s ", dayp[0].id);
            sort(dayp.begin(), dayp.begin() + dayp.size(), cmpo);
            printf("%s\n", dayp[dayp.size() - 1].id);
        }
    }

    return 0;
}

 

搞掂…………
分享到:
评论

相关推荐

Global site tag (gtag.js) - Google Analytics